Deprecated API

  • この会議室に新しいトピックを立てることはできません
  • この会議室ではゲスト投稿が禁止されています

投稿ツリー


前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2013/9/2 20:53
品川地蔵  管理人   投稿数: 318
 現在は全てCocoaで開発しています。SDKを新しいものに変えると、表題のDeprecated APIという警告フラグが増えます(^_^;   この意味は「非推奨。将来使えなくなるかも知れないよ。」ということです。今は10.7SDKを使用していますが、この春にテスト的にSimpleDEMViewerを10.8SDKでコンパイルしたところ pi 定数と、Delay() 関数が deprecatedとなりました。piを何でdeprecatedにする必要があるんだ?とは思いましたが、これは単純に定義し直せばよいだけなので、大きな問題はありません。
 Delay()はCPUを使用せずに一定時間、時間を消費するものですが、UIの調整などに便利に使っています。多くは単純なロジック変更で移し替えられたのですが、3ヶ所残りました。かなり面倒なロジック変更が必要になりそうです。考えあぐねて放置していたのですが、先日再びコンパイルしてみたら、piと共に警告が出なくなっていました。むむ、SDKのバグだったのか、クレームが多くて方針変更になったのか、何にせよ一安心でした。
 今のところ10.8の新機能を使う予定はないので、未だしばらくは10.7SDKのままです。

--
## 品川地蔵 ##

  条件検索へ


Portuguese | English | German | Greek | Japanese | Korean | Russian | T-Chinese top
Powered by XOOPS Cube 2.2 © 2001-2012 XOOPS Cube Project