Deprecated API

投稿ツリー

  • なし Deprecated API (品川地蔵, 2013/9/2 20:53)

このトピックの投稿一覧へ

品川地蔵

なし Deprecated API

msg# 1
depth:
0
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2013/9/2 20:53
品川地蔵  管理人   投稿数: 338
 現在は全てCocoaで開発しています。SDKを新しいものに変えると、表題のDeprecated APIという警告フラグが増えます(^_^;   この意味は「非推奨。将来使えなくなるかも知れないよ。」ということです。今は10.7SDKを使用していますが、この春にテスト的にSimpleDEMViewerを10.8SDKでコンパイルしたところ pi 定数と、Delay() 関数が deprecatedとなりました。piを何でdeprecatedにする必要があるんだ?とは思いましたが、これは単純に定義し直せばよいだけなので、大きな問題はありません。
 Delay()はCPUを使用せずに一定時間、時間を消費するものですが、UIの調整などに便利に使っています。多くは単純なロジック変更で移し替えられたのですが、3ヶ所残りました。かなり面倒なロジック変更が必要になりそうです。考えあぐねて放置していたのですが、先日再びコンパイルしてみたら、piと共に警告が出なくなっていました。むむ、SDKのバグだったのか、クレームが多くて方針変更になったのか、何にせよ一安心でした。
 今のところ10.8の新機能を使う予定はないので、未だしばらくは10.7SDKのままです。

--
## 品川地蔵 ##

  条件検索へ


ログイン

ユーザー名:


パスワード:





パスワード紛失  |新規登録

投稿一覧
  1. SimpleDEMViewer 7.1.2 品川地蔵 2021/9/2 15:57
  2. SimpleDEMViewer 7.1.1 品川地蔵 2021/8/6 22:03
  3. 地理院地図ビューア 品川地蔵 2021/7/31 10:38
  4. Re: WD My Book Live 品川地蔵 2021/7/7 15:34
  5. WD My Book Live 品川地蔵 2021/6/25 22:07
  6. SimpleDEMViewer 7.1 品川地蔵 2021/6/19 12:55
  7. 基盤地図ビューア5.1 品川地蔵 2021/5/25 22:40
  8. Re: SimpleDEMViewer速度改善 品川地蔵 2021/5/17 11:02
  9. SimpleDEMViewer速度改善 品川地蔵 2021/5/16 22:43
  10. Re: 正距方位図法 品川地蔵 2021/5/16 8:22

Portuguese | English | German | Greek | Japanese | Korean | Russian | T-Chinese top
Powered by XOOPS Cube 2.2 © 2001-2012 XOOPS Cube Project